Daily Ubuntu / Linux news and application reviews.

ads

Tribler 5.3.x Ubuntu
*

Tribler is a decentralized, EU-funded BitTorrent client. That means that you can search for torrents from the peers themselves so you do not have to use external servers. You must have heard of it already as it was featured on many websits (like DownloadSquad, Lifehacker and so on).

Unfortunately is that there are no .deb packages for the latest Tribler 5.3.x and that's really a shame because the latest Tribler is a lot faster then the current 5.2.1 version for which .deb files are available and also it sports a new user interface.

But that of course doesn't mean you can't run the latest Tribler from SVN in Ubuntu (important: tested only in Ubuntu 10.10!) - here's how.


How to run the latest Tribler 5.3.x from SVN in Ubuntu


1. Install the dependencies:
sudo apt-get install python-m2crypto python-wxgtk2.8 python-apsw


2. Get the Tribler code from SVN:

cd && svn co http://svn.tribler.org/abc/branches/release-5.3.x/ tribler

3. Run Tribler:
cd
cd tribler
PYTHONPATH=$PYTHONPATH:.
export PYTHONPATH
python Tribler/Main/tribler.py

4. Optional: create a Tribler launcher:

Yes... those are a lot of commands to run Tribler. But you can create a file, let's call it "Tribler" in your home folder, paste the above commands (the ones required to run Tribler), save the file, then make it executable:
chmod +x Tribler

Then use the newly created file as the Tribler launcher - simply double click it whenever you want to run Tribler.

That's it! Tribler 5.3.x from SVN should run in Ubuntu 10.10 now. Unfortunately I couldn't get VLC to work with Tribler so I couldn't watch / listen to the torrents before they finished downloading but maybe you can figure out how to get it to work. If you do, please let us know how you did it, in the comments!


If you want, you can also run the old Tribler 5.2.1 (but remember, it's a lot slower and doesn't have the nice interface the latest 5.3.x has) for which a .deb is provided, however just installing the .deb won't work in Ubuntu 10.10 - at least in my test. But you can get Tribler 5.2.1 to start in Ubuntu by running the following commands:
if [ -d /usr/lib/python2.6 ] ; then sudo mkdir /usr/lib/python2.6/site-packages; sudo ln -s /usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode /usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode ; fi
if [ -d /usr/lib/python2.8 ] ; then sudo mkdir /usr/lib/python2.8/site-packages; sudo ln -s /usr/lib/python2.8/dist-packages/wx-2.8-gtk2-unicode /usr/lib/python2.8/site-packages/wx-2.8-gtk2-unicode ; fi

Then Tribler 5.2.1 should start.


* No, that's not an XXX Big Buck Bunny in the screenshot but the original Big Buck Bunny by the Blender Foundation - someone though it's funny to label it as "XXX".
«
Next
Newer Post
»
Previous
Older Post